no, pyqt5 is not a dependency for matplotlib. this looks like a conda packaging issue.
Side note: the sourceforge mailing list is deprecated. Please use the python.org version instead (you'll have to re-register).
On Thu, Feb 2, 2017 at 11:43 AM, Osborn, Raymond <[hidden email]> wrote:
I just created a new conda environment with Matplotlib included, and it duly installed matplotlib: 2.0.0-np111py27_0. It installed PyQt5 by default, whereas I need PyQt4, but when I installed PyQt4 (conda install pyqt=4), it automatically downgraded Matplotlib to 1.5.1.
The following packages will be DOWNGRADED due to dependency conflicts:
matplotlib: 2.0.0-np111py27_0 --> 1.5.1-np111py27_0
pyqt: 5.6.0-py27_2 --> 4.11.4-py27_4
qt: 5.6.2-0 --> 4.8.7-4
Is PyQt5 really a dependency for Matplotlib v2? I have been testing release candidate versions of Matplotlib v2 without any problem. This will cause headaches to my users who want the latest features.
Ray Osborn, Senior Scientist
Materials Science Division
Argonne National Laboratory
Argonne, IL 60439, USA
Phone: <a href="tel:(630)%20252-9011" value="+16302529011" target="_blank">+1 (630) 252-9011
Email: [hidden email]