[Matplotlib-devel] REL: Matplotlib 2.2.4 and 3.0.3

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Matplotlib-devel] REL: Matplotlib 2.2.4 and 3.0.3

tcaswell
Folks,

As we get ready for 3.1 (aiming for mid-to-late March), we have tagged 2.2.4 and 3.0.3 bug-fix releases.  Wheels for all three platforms are on pypi for both releases.

3.0.3:

The third and last planned bug-fix release of the 3.0 series

* fix several possible memory leaks
* documentation fixes


2.2.4

The forth bug-fix release of the v2.2 LTS series.

 - Fix a memory leak with PySide2.
 - rename :math: sphinx directive to :mathmpl: to work with sphinx >
   1.8. Both versions are now available if sphinx < 1.8.
 - avoids numpy deprecation warnings.
 - fixes to tests to work with pytest >= 3.8 and the minimum is now
   pytest >= 3.6.

As a reminder, the 2.2 LTS series will continue to support Python 2.7 and get critical bug-fixes until the end of 2019.

In both cases jquery-ui is no longer bundled in git repo and is  downloaded during the install or sdist process. If you are installing from pypi the files will be included, but if you are installing from git you will need internet access the first time you run `pip install .`. The install process tries to cache the files and will not need internel access on future installations.

I big thank you to everyone who worked on these releases done. 

Paul Ivanov was co release manager with me on both releases.

Tom

--
Thomas Caswell
[hidden email]

_______________________________________________
Matplotlib-devel mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-devel