Installation issue

Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Installation issue

Jack_Landis
Dear all,

I'm trying to install matplotlib on my pc (Windows 10). I got this error:

$ python buildall.py
Traceback (most recent call last):
  File "buildall.py", line 58, in <module>
    main(options)
  File "buildall.py", line 11, in main
    utils.build_zlib()
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 136, in build_zlib
    cmd.write(prepare_build_cmd(ZLIB_BUILD_CMD))
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 63, in prepare_build_cmd
    raise RuntimeError('Microsoft VS {} required'.format('2010' if VS2010
else '2008'))
RuntimeError: Microsoft VS 2010 required

I already have "Microsoft Visual C++ 2008 redistributable" installed (I have
2008, 2010, 2012, 2013, 2017 installed). What shall I do?

Thank you very much!



--
Sent from: http://matplotlib.1069221.n5.nabble.com/matplotlib-users-f3.html
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
Reply | Threaded
Open this post in threaded view
|

Re: Installation issue

Benjamin Root
This seems to be an issue with https://github.com/jbmohler/matplotlib-winbuild. You might want to check there first.

On Mon, Dec 3, 2018 at 9:32 AM Jack_Landis <[hidden email]> wrote:
Dear all,

I'm trying to install matplotlib on my pc (Windows 10). I got this error:

$ python buildall.py
Traceback (most recent call last):
  File "buildall.py", line 58, in <module>
    main(options)
  File "buildall.py", line 11, in main
    utils.build_zlib()
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 136, in build_zlib
    cmd.write(prepare_build_cmd(ZLIB_BUILD_CMD))
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 63, in prepare_build_cmd
    raise RuntimeError('Microsoft VS {} required'.format('2010' if VS2010
else '2008'))
RuntimeError: Microsoft VS 2010 required

I already have "Microsoft Visual C++ 2008 redistributable" installed (I have
2008, 2010, 2012, 2013, 2017 installed). What shall I do?

Thank you very much!



--
Sent from: http://matplotlib.1069221.n5.nabble.com/matplotlib-users-f3.html
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users

_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
Reply | Threaded
Open this post in threaded view
|

Re: Installation issue

Jack_Landis
I have already followed all that instructions...But still it gaves me this error and I can't understand what I'm doing wrong ☹️

On Mon, 3 Dec 2018, 18:38 Benjamin Root <[hidden email] wrote:
This seems to be an issue with https://github.com/jbmohler/matplotlib-winbuild. You might want to check there first.

On Mon, Dec 3, 2018 at 9:32 AM Jack_Landis <[hidden email]> wrote:
Dear all,

I'm trying to install matplotlib on my pc (Windows 10). I got this error:

$ python buildall.py
Traceback (most recent call last):
  File "buildall.py", line 58, in <module>
    main(options)
  File "buildall.py", line 11, in main
    utils.build_zlib()
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 136, in build_zlib
    cmd.write(prepare_build_cmd(ZLIB_BUILD_CMD))
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 63, in prepare_build_cmd
    raise RuntimeError('Microsoft VS {} required'.format('2010' if VS2010
else '2008'))
RuntimeError: Microsoft VS 2010 required

I already have "Microsoft Visual C++ 2008 redistributable" installed (I have
2008, 2010, 2012, 2013, 2017 installed). What shall I do?

Thank you very much!



--
Sent from: http://matplotlib.1069221.n5.nabble.com/matplotlib-users-f3.html
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users

_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
Reply | Threaded
Open this post in threaded view
|

Re: Installation issue

Paul Hobson-2
What I believe Ben means is that since the matplotlib development team doesn't maintain those scripts, this list isn't the best place for your question (as odd as that may seem). My recommendation would be to the look through the open issues at the matplitlib-winbuild repository and check if someone having a similar issue has figured out a solution. If not, you could create a new issue at the repository explaining your predicament.
-Paul

On Mon, Dec 3, 2018 at 2:18 PM Jacopo Landi <[hidden email]> wrote:
I have already followed all that instructions...But still it gaves me this error and I can't understand what I'm doing wrong ☹️

On Mon, 3 Dec 2018, 18:38 Benjamin Root <[hidden email] wrote:
This seems to be an issue with https://github.com/jbmohler/matplotlib-winbuild. You might want to check there first.

On Mon, Dec 3, 2018 at 9:32 AM Jack_Landis <[hidden email]> wrote:
Dear all,

I'm trying to install matplotlib on my pc (Windows 10). I got this error:

$ python buildall.py
Traceback (most recent call last):
  File "buildall.py", line 58, in <module>
    main(options)
  File "buildall.py", line 11, in main
    utils.build_zlib()
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 136, in build_zlib
    cmd.write(prepare_build_cmd(ZLIB_BUILD_CMD))
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 63, in prepare_build_cmd
    raise RuntimeError('Microsoft VS {} required'.format('2010' if VS2010
else '2008'))
RuntimeError: Microsoft VS 2010 required

I already have "Microsoft Visual C++ 2008 redistributable" installed (I have
2008, 2010, 2012, 2013, 2017 installed). What shall I do?

Thank you very much!



--
Sent from: http://matplotlib.1069221.n5.nabble.com/matplotlib-users-f3.html
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users

_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
Reply | Threaded
Open this post in threaded view
|

Re: Installation issue

tcaswell
If you are using conda it may also be worth looking at the recipe build script and / or the installation.

Our official window install install instructions (https://matplotlib.org/users/installing.html#build-windows ) point at matplotlib-winbuild so I think this is our problem to either fix or own complete install documentation in our docs.

Tom




On Mon, Dec 3, 2018 at 5:47 PM Paul Hobson <[hidden email]> wrote:
What I believe Ben means is that since the matplotlib development team doesn't maintain those scripts, this list isn't the best place for your question (as odd as that may seem). My recommendation would be to the look through the open issues at the matplitlib-winbuild repository and check if someone having a similar issue has figured out a solution. If not, you could create a new issue at the repository explaining your predicament.
-Paul

On Mon, Dec 3, 2018 at 2:18 PM Jacopo Landi <[hidden email]> wrote:
I have already followed all that instructions...But still it gaves me this error and I can't understand what I'm doing wrong ☹️

On Mon, 3 Dec 2018, 18:38 Benjamin Root <[hidden email] wrote:
This seems to be an issue with https://github.com/jbmohler/matplotlib-winbuild. You might want to check there first.

On Mon, Dec 3, 2018 at 9:32 AM Jack_Landis <[hidden email]> wrote:
Dear all,

I'm trying to install matplotlib on my pc (Windows 10). I got this error:

$ python buildall.py
Traceback (most recent call last):
  File "buildall.py", line 58, in <module>
    main(options)
  File "buildall.py", line 11, in main
    utils.build_zlib()
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 136, in build_zlib
    cmd.write(prepare_build_cmd(ZLIB_BUILD_CMD))
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 63, in prepare_build_cmd
    raise RuntimeError('Microsoft VS {} required'.format('2010' if VS2010
else '2008'))
RuntimeError: Microsoft VS 2010 required

I already have "Microsoft Visual C++ 2008 redistributable" installed (I have
2008, 2010, 2012, 2013, 2017 installed). What shall I do?

Thank you very much!



--
Sent from: http://matplotlib.1069221.n5.nabble.com/matplotlib-users-f3.html
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users


--
Thomas Caswell
[hidden email]

_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
Reply | Threaded
Open this post in threaded view
|

Re: Installation issue

anntzer.lee
I would suggest removing the link to mpl-winbuild (which appears to not have been updated for 4 years) and state something to the effect of
- either use the built wheels/conda packages (I think this is what the OP needs)
- or use conda to get libpng set up
- or set it up on your own.
Once libpng and a recent enough MSVC are present, building Matplotlib oneself is "reasonably" straightforward.
Antony

On Tue, Dec 4, 2018 at 2:39 PM Thomas Caswell <[hidden email]> wrote:
If you are using conda it may also be worth looking at the recipe build script and / or the installation.

Our official window install install instructions (https://matplotlib.org/users/installing.html#build-windows ) point at matplotlib-winbuild so I think this is our problem to either fix or own complete install documentation in our docs.

Tom




On Mon, Dec 3, 2018 at 5:47 PM Paul Hobson <[hidden email]> wrote:
What I believe Ben means is that since the matplotlib development team doesn't maintain those scripts, this list isn't the best place for your question (as odd as that may seem). My recommendation would be to the look through the open issues at the matplitlib-winbuild repository and check if someone having a similar issue has figured out a solution. If not, you could create a new issue at the repository explaining your predicament.
-Paul

On Mon, Dec 3, 2018 at 2:18 PM Jacopo Landi <[hidden email]> wrote:
I have already followed all that instructions...But still it gaves me this error and I can't understand what I'm doing wrong ☹️

On Mon, 3 Dec 2018, 18:38 Benjamin Root <[hidden email] wrote:
This seems to be an issue with https://github.com/jbmohler/matplotlib-winbuild. You might want to check there first.

On Mon, Dec 3, 2018 at 9:32 AM Jack_Landis <[hidden email]> wrote:
Dear all,

I'm trying to install matplotlib on my pc (Windows 10). I got this error:

$ python buildall.py
Traceback (most recent call last):
  File "buildall.py", line 58, in <module>
    main(options)
  File "buildall.py", line 11, in main
    utils.build_zlib()
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 136, in build_zlib
    cmd.write(prepare_build_cmd(ZLIB_BUILD_CMD))
  File
"C:\Users\laj\AppData\Local\Programs\Python\Python37\Lib\site-packages\matplotlib-winbuild\utils.py",
line 63, in prepare_build_cmd
    raise RuntimeError('Microsoft VS {} required'.format('2010' if VS2010
else '2008'))
RuntimeError: Microsoft VS 2010 required

I already have "Microsoft Visual C++ 2008 redistributable" installed (I have
2008, 2010, 2012, 2013, 2017 installed). What shall I do?

Thank you very much!



--
Sent from: http://matplotlib.1069221.n5.nabble.com/matplotlib-users-f3.html
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users


--
Thomas Caswell
[hidden email]
_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users

_______________________________________________
Matplotlib-users mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/matplotlib-users